一方向のカレンダー同期に関する問題のトラブルシューティング
環境
- Microsoft® Exchange 用 BlackBerry® Enterprise Server ソフトウェアバージョン 3.6 以降
問題
BlackBerry デバイスは Microsoft Outlook® カレンダーと同期できません。問題は BlackBerry Enterprise Server に関連するものと考えられます。
原因
考えられる原因
この問題は次のいずれかの理由により発生した可能性があります。
- 不適切な権限
- 不適切なバイナリファイルのバージョン
解決策
この問題には 2 つの解決策が考えられます。
原因 1
不適切な権限
解決策
- Microsoft Exchange Server レベルの送信者権限は、ストレージグループレベル、および各ストレージグループにより継承される必要があります。 メールボックスストアレベルの権限を確認し、BlackBerry Enterprise Server 管理アカウントが、すべての適切な権限を継承していることを確認します。 BlackBerry Enterprise Server 管理アカウントに権限を割り当てる方法については、KB02276 を参照してください。
- 次のいずれかのグループのメンバーの場合、BlackBerry Enterprise Server 管理アカウントが拒否されることがあります。
- ドメイン管理者 - このアカウントは、すべての Microsoft Exchange 2000/2003 組織において継承された拒否権を持っています。
- エンタープライズ管理者 - このアカウントは、すべての Microsoft Exchange 2000/2003 組織において継承された拒否権を持っています。
- Exchange の完全な管理者権限を持つグループ - このアカウントは、すべての Microsoft Exchange 2000/2003 組織において継承された拒否権を持っています。
BlackBerry Enterprise Server 管理アカウントが、ドメインユーザーのみ、および BUILTIN\Administrators(必要な場合)のメンバーであることを確認してください。 推奨する Microsoft Active Directory® グループの詳細については、KB04557 を参照してください。
原因 2
不適切なバイナリファイルのバージョン
解決策
注意:Microsoft Exchange 2000 System Manager または Microsoft Exchange 5.5 管理ツールを実行している場合、CDO.dll ファイルは提供されません。 CDO.dll ファイルを取得する方法については、KB02937 を参照してください。
CDO.dll ファイルおよび他のバイナリファイルのバージョンが正しくない可能性があります。 すべての適切なファイルバージョンを比較するには、次の手順を実行します。
- BlackBerry Enterprise Server で、次のファイルに対して検索を実行します
- MAPI32.dll
- CDO.dll
- EMSMDB32.dll
- 各ファイルの場所とバージョンを記録します。
- すべての Microsoft Exchange Server でこの検索を実行します。
- BlackBerry Enterprise Server と Microsoft Exchange Server のファイルのバージョンは同一でなければなりません。 バージョンが同一ではない場合、BlackBerry Enterprise Server ソフトウェアをアップグレードする必要があります。
- ファイルバージョンが一致する場合は、正しい CDO.dll ファイルが使用されていることを確認します。 詳細については、KB04912 を参照してください
注意:Microsoft Exchange 2003 System Manager を実行するには、BlackBerry Enterprise Server ソフトウェアバージョン 3.6 サービスパック 7、または BlackBerry Enterprise Server ソフトウェアバージョン 4.0 サービスパック 4 以降を実行している必要があります。 詳細については、KB04586 を参照してください。