エンタープライズアクティベーションプロセスが「サービスを待機しています」ステータスで応答を停止する
環境
- BlackBerry® Enterprise Server ソフトウェアバージョン 4.0 以降
問題
エンタープライズアクティベーションプロセスが「サービスを待機しています」ステータスで応答を停止します。
原因
この問題は次のいずれかの理由により発生する可能性があります。
- BlackBerry Policy Service がサービスブックと IT ポリシーを処理しています。
- 破損した状態データベースまたはプロファイルドキュメントが存在します(IBM® Lotus® Domino® のみ)。
- Microsoft® XML Parser(MSXML)のバージョンが 4.20.9818 Service Pack 2 以前です。
- BlackBerry Policy Service が応答しない状態になっています。
解決方法
それぞれの原因に対応した解決策を実行してください。
原因 1
BlackBerry Policy Service がサービスブックと IT ポリシーを処理している。
解決策
BlackBerry Policy Service がサービスブックと IT ポリシーを処理し終えるまでしばらく待ちます。
対処方法
BlackBerry デバイスをコンピュータに接続し、BlackBerry® Desktop Manager からエンタープライズアクティベーションプロセスを開始するよう、BlackBerry デバイスユーザーに指示します。
原因 2(IBM Lotus Domino のみ)
破損した状態データベースまたはプロファイルドキュメントが存在する。
解決策
次の手順に従います。
- BlackBerry デバイスユーザーを BlackBerry Enterprise Server から削除します。
- BlackBerry デバイスユーザーのプロファイルドキュメントを BlackBerry プロファイルデータベースから削除します。
- BlackBerry デバイスユーザーの状態データベースを削除します。
- BlackBerry デバイスユーザーを BlackBerry Enterprise Server に追加します。
- エンタープライズアクティベーションパスワードを設定します。
- BlackBerry デバイスでエンタープライズアクティベーションプロセスを開始します。
原因 3
Microsoft XML Parser(MSXML)のバージョンが 4.20.9818 Service Pack 2 以前である。
解決策
Microsoft XML Parser 4.20.9818 Service Pack 2 をインストールします。 ソフトウェアを取得するには、Microsoft の Web サイト(http://www.microsoft.com/downloads/)にアクセスします。
原因 4
BlackBerry Policy Service が応答しない状態になっている。 BlackBerry Policy Service の状態を確認するには、現在の日付の BlackBerry Policy Service(POLC)ログファイルを確認し、ログファイル
<HOSTNAME>_POLC_<date>.txt が存在することを確認します。 存在する場合は、ログファイルが切り捨てられていないこと、および現在のタイムスタンプが含まれていることを確認します。
解決策
BlackBerry Policy Service を停止します。
- [スタート] > [ファイル名を指定して実行]に移動します。
- [名前]フィールドに「services.msc」と入力します。
- 表示される画面で BlackBerry Policy Service を探します。
- [停止]をクリックします。
BlackBerry Policy Service の停止に失敗した場合は、次の手順に従います。
- [タスクマネージャ]を開きます。
- [プロセス]タブで、[イメージ名]で並べ替えます。
- リストから ITAdminServer.exe を探し、[プロセスの終了]をクリックします。
- リストからプロセスが削除されたら、BlackBerry Policy Service を再度起動します。
これで、POLC ログが存在し、エンタープライズアクティベーションプロセスが動作します。