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一方向のワイヤレスメール更新

文書 ID: KB10720
最終更新日時: 11/5/2007
文書の種類: Support

環境

  • BlackBerry® デバイス
  • BlackBerry® Enterprise Server ソフトウェアバージョン 4.0 以降
  • BlackBerry® Professional Software
  • Microsoft® Exchange
  • Microsoft Outlook®
  • Novell® GroupWise® 



問題

Microsoft Outlook で削除済みまたは開封済みのメッセージが、BlackBerry デバイス上では削除済みまたは開封済みとして表示されません。 ワイヤレスメール更新は、BlackBerry デバイスから削除したメッセージに対しては正しく機能しています。




原因

考えられる原因 

このエラーには、複数の原因が考えられます。

  1. BlackBerry デバイスで Desktop[CMIME]サービスブックが正しく機能していません。
  2. BlackBerry デバイスソフトウェアに問題があるためにワイヤレスメール更新が機能していません。
  3. BlackBerry デバイスのデータベースが破損しています。
  4. BlackBerry Enterprise Server の MAPI(Messaging Application Programming Interface)サブシステムでメモリリークが発生しています。



解決策

この問題に対して考えられる原因は次のとおりです。


原因 1

BlackBerry デバイスで Desktop[CMIME]サービスブックが正しく機能していません。

解決策

Desktop[CMIME]サービスブックを削除して、BlackBerry Enterprise Server から再送信します。

  1. BlackBerry デバイスで、[オプション] > [詳細オプション] >[サービスブック]に移動します。
  2. Desktop[CMIME]サービスブックを選択して削除します。
  3. BlackBerry Manager で、適切な BlackBerry デバイスのユーザーを見つけます。
  4. ITAdmin に移動して、[サービスブックを再送信]を選択します。

原因 2

BlackBerry デバイスソフトウェアに問題があるためにワイヤレスメール更新が機能していません。

解決策

BlackBerry デバイスで、ワイヤレスメール更新のオプションをオフにしてから、再度オンにします。

  1. [メッセージ] > [オプション] > [メール更新]に移動します。
  2. [ワイヤレス更新]オプションを[いいえ]に設定し、[保存]をクリックします。
  3. [ワイヤレス更新]オプションを[はい]に設定し、[保存]をクリックします。

原因 3

BlackBerry デバイスのデータベースが破損しています。

解決策

破損しているデータベースをもう一度作成します。

注意:古いメッセージは BlackBerry デバイスから削除されます。

  1. BlackBerry Desktop Manager で、[バックアップと復元]をダブルクリックします。 
  2. [詳細]をクリックし、次のデータベースフィールドをクリアします。 
    • Folder 
    • Folder ID 
    • Messages 
    • Purged Messages 
    • Service Books 
  3. 次の操作のいずれかを実行します。
    • ワイヤレスネットワークを介して BlackBerry デバイスをアクティブにします。

      注意:詳細については、『BlackBerry Wireless Enterprise Activation Technical Overview』(BlackBerry ワイヤレスエンタープライズアクティベーションの技術概要)ホワイトペーパーの「Enabling wireless enterprise activation」(ワイヤレスエンタープライズアクティベーションの有効化)セクションを参照してください。

    • コンピュータに BlackBerry デバイスを接続した状態で、BlackBerry Desktop Manager で新しい暗号化キーを生成します。

    注意:詳細については、KB02740 を参照してください。 

  4. BlackBerry デバイスで[メール更新]設定を設定します。 
    1. BlackBerry デバイスのホームスクリーンで、[メッセージ]をクリックします。 
    2. メニューを表示して、[オプション]を選択します。 
    3. [メール更新]を選択します。 
    4. [ワイヤレス更新]フィールドをクリックし、[変更]を選択します。 
    5. [オン]を選択します。 
    6. メニューを表示し、[保存]を選択します。

原因 4

BlackBerry Enterprise Server の MAPI サブシステムでメモリリークが発生しています。

解決策

次のアプリケーションログエラーを確認して、これが原因であることを確認します。

イベントタイプ:警告
イベントソース:BlackBerry Messaging Agent BES01 Agent 1
イベントカテゴリ:なし
イベント ID:20265
日付:<日付>
時刻:<時刻>
ユーザー:N/A
コンピュータ:<BackBerry Enterprise Server コンピュータ>
説明:
ソース(BlackBerry Messaging Agent BSFS01 Agent 1)でイベント ID(20265)の記述を見つけることができません。 リモートコンピュータからメッセージを表示するために必要なレジストリ情報またはメッセージ DLL ファイルが、ローカルコンピュータに存在しない可能性があります。 この記述を取得するために /AUXSOURCE= フラグを使用できる可能性があります。詳細については、ヘルプとサポートを参照してください。 次の情報はイベントの一部です:{<ユーザー>@<ドメイン>} MAPIMailbox::GetMessageStatusUpdates - QueryRows (0x8007000e) failed.

イベントタイプ:警告
イベントソース:BlackBerry Messaging Agent BES01 Agent 1
イベントカテゴリ:なし
イベント ID:20176
日付:日付
時刻:時刻
ユーザー:N/A
コンピュータ:<BackBerry Enterprise Server コンピュータ>
説明:
ソース(BlackBerry Messaging Agent BSFS01 Agent 1)でイベント ID(20176)の記述を見つけることができません。 リモートコンピュータからメッセージを表示するために必要なレジストリ情報またはメッセージ DLL ファイルが、ローカルコンピュータに存在しない可能性があります。 この記述を取得するために /AUXSOURCE= フラグを使用できる可能性があります。詳細については、ヘルプとサポートを参照してください。 次の情報はイベントの一部です:{<ユーザー>@<ドメイン>} GetNewMessages() failed: ERR_RESOURCE_ALLOC

これらのエラーが発生する最も大きな原因は、Microsoft Exchange 2003 Service Pack 1 バージョンのファイルにあります。 Microsoft Exchange 2003 Service Pack 2 にアップグレードすると、この問題は解決します。

注意:Microsoft Exchange 2003 Service Pack 2 System Tools は、次のバージョンの BlackBerry Enterprise Server でのみサポートされています。

  • BlackBerry Enterprise Server ソフトウェアバージョン 3.6 サービスパック 7(3.6.7)
  • BlackBerry Enterprise Server ソフトウェアバージョン 4.0 サービスパック 4(4.0.4)
  • BlackBerry Enterprise Server ソフトウェアバージョン 4.1(4.1.0)

詳細については、KB04586 を参照してください。

注意:メモリリークエラーに関する情報およびメモリリークエラーを原因として発生する恐れのある症状については、KB03665 を参照してください。




追加情報

これらの条件に当てはまる場合は、次のテストを実行します。

  • BlackBerry デバイスのユーザーが Microsoft Outlook で[Exchange キャッシュモードを使う]をオンにしている。
  • Microsoft Outlook から削除されたメールだけが、BlackBerry デバイスユーザーの BlackBerry デバイスで更新されていない。

この問題が解決したかどうかをテストするには、次の手順を実行します。

  1. BlackBerry デバイスのユーザーとして、Microsoft Outlook Web Access(利用可能な場合)または別のワークステーションにログインします。
  2. メールを削除します。

注意:このテストに失敗する場合は、BlackBerry デバイスユーザーのオフラインメールボックス(Outlook.ost)ファイルが破損しています。 

このファイルを削除することを BlackBerry デバイスのユーザーが許可した場合、または Microsoft Outlook アカウントをオフラインで使用しない場合、次の手順に従います。 

  1. Microsoft Outlook を終了します。
  2. 次の場所に移動します。
    C:\Documents and Settings\<ユーザープロファイル>\Local Settings\Application Data\Microsoft\Outlook\
    outlook.ost ファイルの名前を outlook.ost.old に変更します。
  3. Microsoft Outlook を起動します。
  4. Microsoft Outlook からメールを削除します。
  5. BlackBerry デバイスで[メッセージ]に移動し、メニューを表示して[最新の情報に更新]を選択します。

これにより、BlackBerry デバイスユーザーのメールボックスのオフラインコピーが削除されます。 BlackBerry デバイスユーザーが Microsoft Outlook をオフラインで使用する場合は、もう一度完全に同期するまで、メールの一部を利用できなくなる場合があります。



製品&サービス:

  • Microsoft Exchange 用 BlackBerry Enterprise Server
  • Novell GroupWise 用 BlackBerry Enterprise Server
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