サポート

ローカルナビゲーション

ホーム > サポート > Technical Knowledge Center

戻る

トランザクションエラー - 不正な形式

文書 ID: KB10126
最終更新日時: 6/28/2007
文書の種類: Support

環境

  • BlackBerry® デバイス
  • BlackBerry® Desktop Manager
  • BlackBerry® Enterprise Server



問題

BlackBerry デバイスのユーザーがメールを送信しようとすると、次のエラーメッセージが表示されます。

トランザクションエラー - 不正な形式




原因

考えられる原因

このエラーは、次のいずれかの理由により発生した可能性があります。

  • BlackBerry Desktop Manager が BlackBerry® Desktop Redirector 用に設定されている。
  • BlackBerry Desktop Manager が BlackBerry Enterprise Server と通信できない。



解決策

この問題を解決するには、次のいずれかを実行してください。


解決策 1

注意:この解決策を実行するには、BlackBerry デバイスおよび BlackBerry Enterprise Server へのアクセスが必要です。

次の手順に従います。

  1. コンピュータで[コントロールパネル]を開き、[プログラムの追加と削除]を選択します。
  2. [BlackBerry Desktop Software]をハイライトし、[変更と削除] > [次へ]をクリックします。
  3. [変更]を選択し、[次へ] > [次へ]をクリックします。
  4. [BlackBerry Enterprise Server]または[BlackBerry Desktop Redirector]を選択し、[次へ]をクリックします。
  5. BlackBerry デバイスユーザーに該当するメッセージングシステムを選択し、[次へ]をクリックします。
  6. [BlackBerry Enterprise Server を使用してメッセージをリダイレクトする]を選択し、[次へ] > [次へ]をクリックします。
  7. [インストール] > [完了]をクリックします。
  8. デスクトップサービスブックをすべて削除します。 詳細については、KB05010 を参照してください。
  9. BlackBerry Enterprise Server の BlackBerry Desktop Manager で、サービスブックを BlackBerry デバイスに再送信します。 詳細については、KB03577 を参照してください。

解決策 2

次の手順に従います。

  1. BlackBerry デバイスアプリケーションを再インストールします。 詳細については、KB11320 を参照してください。
  2. BlackBerry デバイスアプリケーションを更新します。 詳細については、KB03621 を参照してください。

解決策 3

上記の方法を実行しても解決しない場合は、次の手順に従ってください。

警告:次の操作手順は、コンピュータのレジストリ変更を伴います。 ただし、Microsoft Windows® オペレーティングシステムに重大な障害をもたらす可能性があるため、 変更を行う前に、レジストリエントリの記録およびバックアップを行ってください。

注意:キーを削除するときに Blackberry Desktop Manager と Microsoft Outlook® が両方とも閉じていることを確認してください。

  1. HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles レジストリキーのバックアップを作成し、次の手順に従ってレジストリキーを削除します。
    1. コンピュータで[スタート] > [ファイル名を指定して実行]をクリックし、「regedit」と入力します。
    2. HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles レジストリキーのバックアップを作成し、レジストリキーを削除します。
  2. キーを削除したら、Outlook を開き、ウィザードの指示に従って MAPI(Messaging Application Programming Interface)の新しいプロファイルを作成します。
  • Microsoft Outlook XP MAPI プロファイルの作成方法については、KB01528 を参照してください。
  • Microsoft Outlook 2000 MAPI プロファイルの作成方法については、KB02083 を参照してください。



追加情報

この問題を検証するには、BlackBerry デバイスで Desktop [CMIME] サービスブックの[UID]フィールドを確認します。 詳細については、KB04330「Desktop [CMIME] サービスブックの更新」の手順 1 と 2 を参照してください。 [UID]フィールドには、BlackBerry デバイスユーザーのメールアドレスが含まれますが、BlackBerry Enterprise Server の SRP(Server Routing Protocol)ID(12345678 など)が必要になります。



製品&サービス:

  • BlackBerry Enterprise Server
  • BlackBerry デバイス
  • BlackBerry Desktop Software