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1 人以上の BlackBerry デバイスユーザーに対する一方向のワイヤレスカレンダー同期

文書 ID: KB05270
最終更新日時: 7/11/2007
文書の種類: Support

環境

  • BlackBerry® Enterprise Server ソフトウェアバージョン 2.1~4.1
  • BlackBerry® Mobile Data System(BlackBerry MDS)
  • Microsoft® Exchange 5.5、Microsoft Exchange 2000、および Microsoft Exchange 2003
  • Microsoft Windows® 2000
  • Microsoft Windows Server® 2003



問題

Microsoft Outlook® カレンダーから BlackBerry デバイスカレンダーへの一方向でのみ、ワイヤレスカレンダー同期が行われます。 最初のワイヤレスカレンダー同期は正常に行われました。




原因

この問題は次のいずれかの理由により発生した可能性があります。

  1. BlackBerry Enterprise Server サービスが BlackBerry Enterprise Server サービスアカウントで実行されていない。
  2. BlackBerry Enterprise Server サービスアカウントに適切な権限がない。
  3. Collaboration Data Object(CDO)が存在しない、または Microsoft Exchange 環境でサポートされていない。
  4. BlackBerry Enterprise Server サービスアカウントがドメイン管理者である。



解決策

この問題に対して考えられる原因は次のとおりです。

原因 1

BlackBerry Enterprise Server サービスが BlackBerry Enterprise Server サービスアカウントで実行されていない。

解決策

すべての BlackBerry Enterprise Server サービスが、適切な BlackBerry Enterprise Server サービスアカウントのもとで実行されていることを確認します。

注意:いくつかの BlackBerry Enterprise Server サービスはローカルシステムアカウントで実行されます(BlackBerry Attachment Service または BlackBerry MDS Services - Apache Tomcat™ Service など)。

正しいアカウントが指定されていることを確認するには、次の手順に従います。

  1. 管理ツールで[サービス]を選択し、[BlackBerry Service]をダブルクリックします。
  2. [ログオン]タブで、正しい BlackBerry Enterprise Server サービスアカウント名が指定されていることを確認します。
  3. 不適切な BlackBerry Enterprise Server サービスアカウント名が指定されている場合は、次の手順のいずれかを実行します。
    • 管理者アカウントまたは別の管理アカウントを使用して BlackBerry Enterprise Server がインストールされている場合は、サービスアカウントを BlackBerry Enterprise Server サービスアカウントに切り替えます。 詳細については、以下の記事のいずれかを参照してください。
      • BlackBerry Enterprise Server ソフトウェアバージョン 3.6 については、KB04334 を参照してください。
      • BlackBerry Enterprise Server ソフトウェアバージョン 4.0 および 4.1 については、KB04293 を参照してください。

      または

    • BlackBerry Enterprise Server サービスアカウントを使用して BlackBerry Enterprise Server がインストールされている場合は、サービスアカウントを BlackBerry Enterprise Server サービスに対応するアカウントに切り替えます。

注意:このケースは、BlackBerry Enterprise Server サービスアカウントを使用して、BlackBerry Enterprise Server サービスパックまたはホットフィックスがインストールされなかった場合に発生します。


原因 2

BlackBerry Enterprise Server サービスアカウントに適切な権限がない。

解決策

BlackBerry デバイスユーザーのメールボックスを更新するには、適切な権限が必要です。 次の手順に従って、BlackBerry Enterprise Server サービスアカウントの権限を変更します。

Microsoft Exchange Server 2000 および Microsoft Exchange Server 2003

  1. Exchange System Manager で Exchange 管理グループ名を右クリックして[制御の委任]をクリックします。
  2. [次へ]をクリックしてから[追加]をクリックし、[制御の委任]ウィンドウを開きます。
  3. [参照]をクリックして[ユーザー、コンピュータ、またはグループの選択]ウィンドウを開き、新しいサービスアカウントを選択します。
  4. [ロール]ドロップダウンリストで[Exchange 管理者(参照のみ可)]を選択して[OK]をクリックします。
  5. [次へ]をクリックし、[完了]をクリックします。
  6. Exchange System Manager を開き、 Administrative Groups/First Administrative Group/Serversに移動します。
  7. Microsoft Exchange Server の名前を右クリックして[プロパティ]をクリックし、[セキュリティ]タブをクリックします。
  8. [親からの継承可能なアクセス許可をこのオブジェクトとすべての子オブジェクトに伝達できるようにします]チェックボックスがオンになっていることを確認します。
  9. サービスアカウント名を選択し、適切なチェックボックスをオンにして[インフォメーションストアの管理][受信者]、および[送信者]の権限を許可します。
  10. サービスアカウントに対して拒否された権限が選択されていないことを確認します。
  11. [適用]をクリックし、[OK]をクリックします。
  12. 管理ツールで[Active Directory ユーザーとコンピュータ]を選択します。
  13. BlackBerry Enterprise Server サービスアカウントを右クリックして[プロパティ]をクリックします。
  14. [次のメンバ]タブで、ドメインユーザーがリストに表示されていることを確認します。
  15. BlackBerry Enteprise Server がドメインコントローラにインストールされている場合は、管理者が表示されていることを確認します。

Microsoft Exchange Server 5.5

Exchange Administrator で、サイトコンテナと設定コンテナの両方について、新しいサービスアカウントのサービスアカウント管理者権限を有効にします。 詳細については、KB00886 を参照してください。 権限の設定の詳細については、Microsoft Exchange Server 5.5 のドキュメントを参照してください。

重要:サービスアカウントが、必要な権限を拒否できるグループのメンバーではないことを確認してください。 詳細については、KB04557 を参照してください。


原因 3

Collaboration Data Object(CDO)が存在しない、または Microsoft Exchange 環境でサポートされていない。

解決策

CDO.DLL ファイルが Microsoft Exchange 環境でサポートされていることを確認します。

Microsoft Exchange 2000 および Microsoft Exchange 2003 の場合

  1. Exchsrvr\bin ディレクトリに移動して、Microsoft Exchange Server の CDO.DLL ファイルのバージョンを確認します。
  2. BlackBerry Enterprise Server の CDO.DLL ファイルが Microsoft Exchange Server の CDO.DLL ファイルのバージョンと同じか、またはそれ以降のバージョンのものであることを確認します。

    注意:複数のバージョンの CDO.DLL ファイルが存在する場合は、すべてのコピーが一致することを確認してください。

  3. コマンドプロンプトで、CDO.DLL ファイルが配置されているディレクトリに移動します。
  4. regsvr32 cdo.dll と入力して Enter キーを押します。 ファイルが正しく登録されたことを示す確認メッセージが表示されます。

Microsoft Exchange 5.5 の場合

  1. System32 ディレクトリに移動して、Microsoft Exchange Server の CDO.DLL ファイルのバージョンを確認します。
  2. BlackBerry Enterprise Server の CDO.DLL ファイルが Microsoft Exchange Server の CDO.DLL ファイルのバージョンと同じか、またはそれ以降のバージョンのものであることを確認します。

    注意:複数のバージョンの CDO.DLL ファイルが存在する場合は、すべてのコピーが一致することを確認してください。

  3. コマンドプロンプトで、CDO.DLL ファイルが配置されているディレクトリに移動します。
  4. regsvr32 cdo.dll と入力して Enter キーを押します。 ファイルが正しく登録されたことを示す確認メッセージが表示されます。

注意:CDO.DLL ファイルの入手方法および適用方法については、KB02937 を参照してください。 CDO.DLL ファイルが登録されていることを確認するには、KB04912 を参照してください。


原因 4

BlackBerry Enterprise Server サービスアカウントがドメイン管理者である。

解決策

BlackBerry Enterprise Server サービスアカウントがドメイン管理者ではないことを確認します。




追加情報

BlackBerry Enterprise Server サービスアカウントがドメイン管理者またはエンタープライズ管理者グループのメンバーである場合、送信者権限は自動的に無効になります。 送信者権限がなければ、BlackBerry Enterprise Server は Microsoft Exchange Server 上で BlackBerry デバイスユーザーのカレンダーを更新できません。 サービスアカウントが、ドメイン管理者などの Microsoft Active Directory® グループからこのロールを継承しないこと、またはこのロールのメンバーではないことを確認してください。

KB02466 では、BlackBerry Enterprise Server ソフトウェアバージョン 3.5 に接続したときの一方向のカレンダー同期に関する情報を確認できます。

KB03784 では、ワイヤレスカレンダー同期に影響する、Windows Server 2003 ドメインコントローラのメモリリークに関する情報を確認できます。

Microsoft Support Knowledge Base の記事 821897 では、Microsoft Exchange Server 2003 のすべてのメールボックスにサービスアカウントのアクセスを割り当てる方法に関する追加情報を確認できます。



製品&サービス:

  • Microsoft Exchange 用 BlackBerry Enterprise Server