サポート

ローカルナビゲーション

ホーム > サポート > Technical Knowledge Center

戻る

同期後の未開封マークが、BlackBerry デバイスと Lotus Notes メールデータベースの間で一致しない

文書 ID: KB05253
最終更新日時: 10/25/2007
文書の種類: Support

環境

  • BlackBerry® Device Software
  • BlackBerry Enterprise Server ソフトウェアバージョン 4.0 および 4.1
  • IBM® Lotus® Domino® 6.0.3 または 6.5.3 以前
  • SDR44719
  • SDR50187
  • SDR65372



問題

同期後の開封済みマークが BlackBerry デバイスと IBM Lotus Notes® の間で一致していません。




原因

この問題は、次のいずれかの理由により発生した可能性があります。

  1. BlackBerry Enterprise Server と BlackBerry デバイスユーザーに、管理者と編集者の権限がありません。
  2. メールデータベースの未読マークを複製するように設定されていません。
  3. メールデータベースのクラスタ化されたレプリカ間でフェイルオーバーが実行されました。
  4. IBM Lotus Notes メールクライアントを実行していない間に、未開封マークが一致しなくなりました。
  5. BlackBerry Enterprise Server がフェイルオーバーしたメッセージングサーバーに接続しています。
  6. BlackBerry デバイスユーザーのメールファイルのバージョンが、IBM Lotus Domino 6 以前のものです。



解決策

この問題に対して考えられる原因は次のとおりです。

原因 1

BlackBerry Enterprise Server と BlackBerry デバイスユーザーに、メールデータベースに対する管理者と編集者の権限がありません。

解決策

IBM Lotus Domino 管理クライアントで、次の手順に従います。

  1. [ファイル] > [データベース] > [アクセス制御]に移動します。
  2. アクセス制御リスト(ACL)で、LocalDomainServers または BlackBerry Enterprise Server のいずれかが表示されていることを確認します。 LocalDomainServers が表示されている場合は、BlackBerry Server がこのグループに属していることを確認します。
  3. [種類]が[サーバー]に設定されており、[アクセス権]が[管理者]に設定されていることを確認します。

原因 2

メールデータベースの未読マークを複製するように設定されていません。

解決策

未読マークを複製するように設定します。 この操作を行うには、メールデータベースのレプリカでデータベースのプロパティを確認します。 次に[詳細]タブで[未読マークを複製する]の下の[すべてのサーバー]を選択します。


原因 3

メールデータベースのクラスタ化されたレプリカ間でフェイルオーバーが実行された後に、未開封テーブルの未開封マークが同期されていません。 BlackBerry デバイスユーザーが IBM Lotus Notes でメールデータベースのアイコンをクリックすると、メールクライアントは、セカンダリのメッセージングおよびコラボレーションサーバーにあるレプリカにアクセスします。 その後、BlackBerry デバイスで既読メッセージと未開封メッセージに違いが生じます。

解決策

未開封テーブルを同期するには、IBM Lotus Notes で、クラスタ化されたメールデータベースのレプリカ間で複製を手動で実行します。

注意:複製を手動で完了したら、[表示] > [未読メッセージの表示]の順にクリックします。 未開封のメッセージの数は、メールデータベースレプリカのデータベースアイコンに表示される数(ローカルコンピュータのレプリカコピーを含む)と一致する必要があります。


原因 4

IBM Lotus Notes のメールクライアントが実行されていない、または IBM Lotus Domino サーバーに接続されていない間に、BlackBerry デバイスとメールファイルの間で未開封マークが一致しなくなりました。

解決策

BlackBerry Enterprise Server と IBM Lotus Domino サーバーの両方で、IBM Lotus Domino をバージョン 6.0.4 以降、またはバージョン 6.5.4 以降にアップグレードします。


原因 5

BlackBerry デバイスユーザーのメールファイルが存在する IBM Lotus Domino サーバーが、IBM Lotus Domino クラスタのメンバーです。 この結果、BlackBerry Enterprise Server がフェイルオーバーしたメッセージングサーバーに接続しています。

解決策

BlackBerry Enterprise Server と IBM Lotus Domino サーバーの両方で、IBM Lotus Domino をバージョン 6.0.4 以降、またはバージョン 6.5.4 以降にアップグレードします。 次に、[未読マークを複製する]の下の[クラスタサーバーのみ]オプションを選択します。


原因 6

BlackBerry デバイスユーザーのメールファイルのバージョンが IBM Lotus Domino 6 以前の場合は、BlackBerry Messaging Agent は、関連する BlackBerry デバイスに対して開封/未開封マークを同期しません。

これを確認するには、IBM Lotus Domino 管理クライアントで、次の手順に従います。

  1. [ファイル] > [データベース] > [プロパティ]に移動します。
  2. [i]タブを選択し、ODS(On-Disk Structure)のバージョンを確認します(IBM Lotus Domino 6 では、ODS バージョンは 43)。

対処方法

BlackBerry Enterprise Server 4.0.3 では、レジストリキーを変更してメッセージングエージェントでの開封/未開封マークの確認を有効または無効にすることができます。 レジストリキーにより、BlackBerry Enterprise Server が ODS バージョンを確認するかどうかが制御されます。 この機能を有効にすると、開封/未開封マークのワイヤレス更新は、ODS のバージョンに関係なく実行されます。 

警告:次の操作手順は、コンピュータのレジストリ変更を伴います。 ただし、Microsoft Windows® オペレーティングシステムに重大な障害をもたらす可能性があるため、 変更を行う前に、レジストリエントリの記録およびバックアップを行ってください。

次の手順に従います。

  1. レジストリで、 HKEY_LOCAL_MACHINE\SOFTWARE\Research In Motion\BlackBerry Enterprise Server\Agentsに移動します。
  2. CheckMailTemplateVersionForOTAFM という名前の DWORD 値を作成します。
  3. 次の値のいずれかを割り当てます。
    • 0 BlackBerry Enterprise Server により開封/未開封マークが確認されます。
    • 1 BlackBerry Enterprise Server により開封/未開封マークが確認されません。

重要:IBM Lotus Domino のバージョン 6.0.4 または 6.5.4 以前でこの対処方法を実行すると、更新が一致しないという問題が発生する可能性があるためお勧めしません。




追加情報

詳細については、KB04307 および KB04490 を参照してください。



製品&サービス:

  • IBM Lotus Domino 用 BlackBerry Enterprise Server