サポート

ローカルナビゲーション

ホーム > サポート > Technical Knowledge Center

戻る

送信者権限が取り消されているためメッセージを送信できない

文書 ID: KB04707
最終更新日時: 11/5/2007
文書の種類: Support

環境

  • BlackBerry® Enterprise Server ソフトウェアバージョン 2.1 および Microsoft® Exchange 用バージョン 3.6 ~ 4.1 
  • Microsoft® Exchange Server 2003 Service Pack 1 および 2
  • Microsoft® Exchange Server 2000 Service Pack 3
  • SDR75493
  • SDR82260

背景

この記事は、次の使用環境における Microsoft Exchange Server 2003 および 2000 にあてはまります。

  • Microsoft Exchange Server 2003 Service Pack 1(ストアビルド 7233.28 以降を使用)
  • Microsoft Exchange Server 2003 Service Pack 2(ストアビルド 7650.23 以降を使用)
  • Microsoft Exchange Server 2000 Service Pack 3(ストアビルド 6619.4 以降を使用)

重要:Microsoft Support Knowledge Base の記事 895949 に記載されているホットフィックスを Microsoft Exchange Server 2003 Service Pack 1 または Service Pack 2 に適用する場合、またはホットフィックスを Microsoft Exchange Server 2000 Service Pack 3 に適用する場合は、KB12827 を参照してください。




問題

BlackBerry スマートフォンのユーザーがメールを送信しようとしても送信できず、赤い X マークがメッセージリストのメールの横に表示されます。 [メッセージの状態]フィールドには、次のエラーが表示されます。

  • 一覧にないメッセージエラー
  • コンピュータのメールアプリケーションはメッセージを送信できません

注意:[メッセージの状態]フィールドは、メッセージの[宛先]フィールドの上に表示されます。

BlackBerry Enterprise Server のデバッグログには次のように表示されます。

BlackBerry Enterprise Server ソフトウェアバージョン 4.0 および 4.1

[40700] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} Receiving packet from device, size=111, TransactionId=-2099843783, Tag=147, content type=CMIME, cmd=0x3
[30112] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} Receiving message from device, RefId=1607656887, Tag=147, TransactionId=-2099843783
[20265] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
[20265] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
[20000] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} Send() failed: SUCCESS, Tag=147
[40277] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} Sending message error to device for message 1607656887
[40583] (12/13 15:38:10):{0xFF0} {<ユーザー名>@<ドメイン>} Sending packet to device, Size=46, Tag=222, TransactionId=-1012978472

BlackBerry Enterprise Server ソフトウェアバージョン 3.6 以前

[40700] (12/13 15:38:10):{0x7FC} {<ユーザー名>@<ドメイン>} Receiving packet from device, size=161, TransactionId=-1966367802, Tag=-1091853399, content type=CMIME, cmd=0x3
[30112] (12/13 15:38:10):{0x7FC} {<ユーザー名>@<ドメイン>} Receiving message from device, RefId=1473556709, Tag=-1091853399, TransactionId=-1966367802
[20265] (12/13 15:38:10):{0x7FC} {<ユーザー名>@<ドメイン>} *** MAPI *** MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed.
[20000] (12/13 15:38:10):{0x7FC} {<ユーザー名>@<ドメイン>} Send() failed: ERR_SUBMIT_MAIL, Tag=-1091853399
[40277] (12/13 15:38:10):{0x7FC} {<ユーザー名>@<ドメイン>} Sending message error to device for message 1473556709
[40583] (12/13 15:38:10):{0x7FC} {<ユーザー名>@<ドメイン>} Sending message to device, Size=85, Tag=6420, TransactionId=-1001413813




原因

Microsoft Support Knowledge Base の記事 895949 に記載されているホットフィックスを Microsoft Exchange Server 2003 Service Pack 1 または 2 に適用したり、ホットフィックスを Microsoft Exchange Server 2000 Service Pack 3 に適用したりすると、store.exe ユーティリティによって、メールボックスストアレベルでのインフォメーションストアの管理権限が付与されている Microsoft Exchange Server のすべての管理アカウントの送信者権限が取り消されます。

注意:この問題に関するその他の原因および解決策については、KB00274 を参照してください。




解決策

Microsoft ホットフィックスを適用したかどうかを確認し、それに応じて次の適切な解決策を実行してください。


解決策 1

Microsoft ホットフィックスを適用していない場合は、権限に関する要件を確認してください。 権限に関する要件の解決については、Microsoft Support Knowledge Base の記事 912918 を参照してください。

注意:BlackBerry サービスを再起動する必要はありません。


解決策 2

Microsoft ホットフィックスを適用した場合は、BlackBerry Enterprise Server のソフトウェアバージョンに応じて、次の手順を実行してください。

BlackBerry Enterprise Server ソフトウェアバージョン 4.0 ~ 4.1

  1. 権限に関する要件を確認します。 権限に関する要件の解決については、Microsoft Support Knowledge Base の記事 912918 を参照してください。
  2. BlackBerry Enterprise Server 管理アカウントの Microsoft Exchange Server 権限のキャッシュをクリアするには、次の手順に従います。
    • BlackBerry スマートフォンを 2 時間オフにします。 

または

BlackBerry Router を停止してから起動します。

重要:特定の BlackBerry Enterprise Server サービスを再起動すると、BlackBerry スマートフォンへのメールの送信に遅延が生じます。 詳細については、KB04789 を参照してください。

BlackBerry Router を停止してから起動するには、次の手順に従います。

  1. Microsoft® Windows® の[コントロール パネル]で、[管理ツール] > [サービス]を開きます。
  2. [BlackBerry Router]を右クリックし、[停止]をクリックして、2 時間ほど待機します。 
  3. [BlackBerry Router]を右クリックし、[開始]をクリックします。

注意:権限をキャッシュするデフォルトの時間は、Mailbox Cache Age Limit レジストリエントリによって制御されます。 このため、権限キャッシュのクリアに必要な時間は、このレジストリエントリに設定されている値によって異なります。 すべての Microsoft Exchange Server が、デフォルトで 2 時間に設定されています。 Microsoft では、権限キャッシュのクリアのデフォルト時間(120 分)を 20 分に変更することを推奨しています。 Mailbox Cache Age Limit レジストリエントリの値は、使用環境によって異なる場合があります。 この値を参照して、管理アカウントの権限をキャッシュする時間を決定してください。 権限キャッシュをクリアするには、Mailbox Cache Age Limit レジストリエントリに設定された時間が経過するまで待機する必要があります。 その他のオプションについては、Microsoft Support Knowledge Base の記事 912918 を参照してください。

Mailbox Cache Age Limit レジストリエントリの詳細については、Microsoft Support Knowledge Base の記事 327378、または Microsoft TechNet Web サイトの Mailbox Cache Age Limit レジストリエントリを参照してください。

BlackBerry Enterprise Server ソフトウェアバージョン 3.6

  1. 権限に関する要件を確認します。 権限に関する要件の解決については、Microsoft Support Knowledge Base の記事 912918 を参照してください。
  2. BlackBerry Enterprise Server 管理アカウントの Microsoft Exchange Server 権限キャッシュをクリアするには、[コントロール パネル]で[管理ツール] > [サービス]を開きます。
  3. 各 BlackBerry Enterprise Server サービスを右クリックし、各サービスに対して[停止]をクリックします。
  4. 20 分ほど待機します。
  5. 各 BlackBerry Enterprise Server サービスを右クリックし、各サービスに対して[開始]をクリックします。

注意:権限をキャッシュするデフォルトの時間は、Mailbox Cache Age Limit レジストリエントリによって制御されます。 このため、権限キャッシュのクリアに必要な時間は、このレジストリエントリに設定されている値によって異なります。 Microsoft Exchange Server では、デフォルトで 2 時間に設定されています。 Microsoft では、権限キャッシュのクリアのデフォルト時間(120 分)を 20 分に変更することを推奨しています。 Mailbox Cache Age Limit レジストリエントリの値は、使用環境によって異なる場合があります。 この値を参照して、管理アカウントの権限をキャッシュする時間を決定してください。 権限キャッシュをクリアするには、Mailbox Cache Age Limit レジストリエントリに設定された時間が経過するまで待機する必要があります。 その他のオプションについては、Microsoft Support Knowledge Base の記事 912918 を参照してください。

Mailbox Cache Age Limit レジストリエントリの詳細については、Microsoft Support Knowledge Base の記事 327378、または Microsoft TechNet Web サイトの Mailbox Cache Age Limit レジストリエントリを参照してください。

重要:特定の BlackBerry Enterprise Server サービスを再起動すると、BlackBerry スマートフォンへのメッセージの送信に遅延が生じます。 詳細については、KB04789 を参照してください。

保護されたアカウント

Microsoft® Active Directory® のユーザーオブジェクトが保護されているアカウントとメンバーシップを共有しているために、Microsoft® Active Directory® のユーザーアカウントで送信者権限が取り消された場合は、次の手順を実行してください。

注意:保護されたアカウントの一覧と詳細については、Microsoft Support Knowledge Base の記事 907434 を参照してください。

  1. 保護されたアカウントのメンバーシップを Microsoft Active Directory ユーザーオブジェクトから削除します。
  2. 送信者権限をユーザーオブジェクトに再割り当てします。 詳細については、Microsoft Support Knowledge Base の記事 912918 を参照してください。
  3. Microsoft Active Directory のレプリケーションが起動されるまで待機するか、または強制的にレプリケーションを実行します。
  4. 次の操作のいずれかを実行します。
    • BlackBerry スマートフォンのユーザーを BlackBerry Enterprise Server から削除し、20 分ほど待機します。 BlackBerry スマートフォンのユーザーを BlackBerry Enterprise Server にもう一度追加してアクティブにします。
    • BlackBerry Enterprise Server のソフトウェアバージョンによっては、BlackBerry Router または BlackBerry Enterprise Server を停止してから、20 分ほど待機します。 BlackBerry Router または BlackBerry Enterprise Server をもう一度開始します。

      重要:特定の BlackBerry Enterprise Server サービスを再起動すると、BlackBerry スマートフォンへのメッセージの送信に遅延が生じます。 詳細については、KB04789 を参照してください。

ヒント:『How to verify the Exchange 'Send As' permissions』(Exchangeの「送信者」権限の検証方法)オンライントレーニングビデオを表示するには、ここをクリックしてください。




追加情報

Microsoft Active Directory 権限を変更すると、保護されたグループのメンバーである BlackBerry スマートフォンのユーザーは、追加のメールアカウントを作成せずに、メールを BlackBerry スマートフォンから送信できるようになります。 AdminSDHolder Microsoft Active Directory オブジェクトに関連付けられた権限のうち、Microsoft Exchange 更新プログラムによって最近変更された権限を修正する手順については、Microsoft Support Knowledge Base の記事 817433 を参照してください。

重要:この手順は、Microsoft または Research In Motion によって推奨されるものではありません。


2007 年夏時間(DST)に関するパッチと送信者権限

Microsoft の新しい CDO(Collaboration Data Object)更新プログラムを使用して、Microsoft Active Directory 内の各 BlackBerry スマートフォンユーザーの送信者権限を BlackBerry Enterprise Server 管理アカウントでオンにしておく必要があります。  管理アカウントで送信者権限がオンに設定されていないと、BlackBerry スマートフォンユーザーは、BlackBerry スマートフォンからメッセージを送信できません。

新しい BlackBerry スマートフォンユーザーを BlackBerry Enterprise Server に追加する場合、管理者は Microsoft Active Directory 内の BlackBerry Enterprise Server 管理アカウントで送信者権限がオンになっていることを確認する必要があります。 新しい BlackBerry スマートフォンユーザーを BlackBerry Enterprise Server に追加する場合、BlackBerry スマートフォンユーザーは Microsoft Active Directory の親オブジェクトから(グループ権限などを使用して)送信者権限を引き継ぐか、BlackBerry Enterprise Server を通じて送信者権限を BlackBerry スマートフォンユーザーに自動的に設定する必要があります。 これを実行しない場合は、SetSendAsPermission ツールを使用して権限を設定してください。

SetSendAsPermission ツールをダウンロードするには、ここをクリックしてください。 SetSendAsPermission ツールの使用方法については、KB12300 を参照してください。

Microsoft Exchange 2003 Service Pack 2 における 2007 年の DST の変更に関する Microsoft 更新プログラムの詳細については、Microsoft Support Knowledge Base の記事 926666 を参照してください。

2007 年の DST の変更による BlackBerry ソリューションへの影響の詳細については、www.blackberry.com/dst2007 を参照してください。



製品&サービス:

  • Microsoft Exchange 用 BlackBerry Enterprise Server