アプリケーションデータの書き込みまたは更新ができない
環境
- BlackBerry® Desktop Software 2.1~4.2
- BlackBerry® Device Software 4.2
- IBM® Lotus Notes®
- Microsoft® Outlook®
- Microsoft Outlook Express
- Microsoft® Windows® 2000 および XP
- Sage Software ACT!®
問題
BlackBerry スマートフォンとコンピュータの間でオーガナイザデータ(連絡先、カレンダーエントリ、タスク、メモなど)を同期すると、次のエラーメッセージが表示されます。
アプリケーションデータの書き込みまたは更新ができません。
原因
考えられる原因
この問題は、次のいずれかの理由により発生した可能性があります。
- Microsoft Outlook、Sage Software ACT!、IBM Lotus Notes、または IBM® Lotus Organizer® の連絡先の 1 つまたは複数のフィールドに情報がありません。
- BlackBerry スマートフォンに十分なメモリがなく、オーガナイザデータを同期できません。
- BlackBerry スマートフォンユーザーのオーガナイザデータベースに無効な情報が含まれています。
- BlackBerry スマートフォンのアプリケーションデータベースが破損しています。
- IBM Lotus Notes アドレス帳データベースに、BlackBerry® Desktop Manager と互換性のないカスタムテンプレートがあります。
- BlackBerry スマートフォンのアドレス帳が破損しています。
- 一時的なデータベースの破損により、BlackBerry スマートフォンが、カレンダー、メモリスト、またはタスクリストを含むオーガナイザアプリケーションの同期に失敗しています。
- BlackBerry スマートフォンのアドレス帳に空白の連絡先があります。
解決策
この問題については、次のような解決策が考えられます。
注意:エラーが表示されたときに効果的な最初の対応は、BlackBerry スマートフォンをハードリセットすることです。 詳細については、KB02141 を参照してください。
Microsoft Outlook、Sage Software ACT!、IBM Lotus Notes、または IBM Lotus Organizer の連絡先で、次のいずれかのフィールドに情報がありません。
解決策
BlackBerry Desktop Software 4.2 サービスパック 1(4.2.1)以降では、[名]、[姓]、および[会社名]フィールドのいずれかに情報が入力されていない場合でもレコードが認識されます。 BlackBerry Desktop Software 4.2.1 にアップグレードして同期を完了します。 Microsoft Outlook、Sage Software ACT!、IBM Lotus Notes、または IBM Lotus Organizer の連絡先を確認して、[名]、[姓]、および[会社名]フィールドにデータを追加します。 これにより、以後の同期にこれらのデータが含まれます。 この問題の詳細については、KB11366 を参照してください。
BlackBerry スマートフォンに十分な空きメモリがなく、オーガナイザデータをコンピュータと同期できません。
解決策
BlackBerry スマートフォンで使用できるメモリ容量を増やすには、次の手順に従います。
注意:次の手順に進む前に、BlackBerry Desktop Manager で[バックアップと復元]ツールを使用して、BlackBerry スマートフォンのデータベースをバックアップします。 詳細については、KB11625 を参照してください。
BlackBerry Desktop Manager を使用してカレンダーの日付範囲を減らす
カレンダーの日付範囲を減らすことで、BlackBerry スマートフォンで更新する予定またはイベントの数を制限します。 次のいずれかを更新できます。
- すべてのアイテム
- 将来のアイテムのみ
- 日付範囲内のアイテム
日付範囲を減らすことで、BlackBerry スマートフォンで使用できるストレージ領域が増えます。 詳細については、KB05347 を参照してください。
Application Loader を使用して BlackBerry スマートフォンから不要なアプリケーションを削除する
詳細については、KB10376 を参照してください。
BlackBerry スマートフォンユーザーのオーガナイザデータベース(Microsoft Outlook、Sage Software ACT!、IBM Lotus Notes、IBM Lotus Organizer など)に無効な情報が含まれています。
注意:次の手順に進む前に、連絡先エントリが、原因 1 に記載された問題の影響を受けていないことを確認します。
解決策
詳細ログをオンにして、無効な情報を含むレコードを特定し、無効な情報を削除します。
- 詳細ログをオンにします。 詳細については、KB01451 を参照してください。
- 無効な情報を含むレコードを特定したら、コンピュータでエントリを確認して削除します。
BlackBerry スマートフォンのアプリケーションデータベース(アドレス帳、カレンダー、メモ帳、またはタスク)が破損しています。
解決策
破損したデータベースをクリアします。
- 破損したデータベースを特定します。 詳細については、KB03069 を参照してください。
- 破損したデータベースをバックアップします。 詳細については、KB11297 を参照してください。
- 破損したデータベースをクリアします。
- [バックアップと復元]を開き、[詳細]をクリックします。
- 破損したデータベースを選択し、[クリア]をクリックします。
- BlackBerry スマートフォンを同期します。
IBM Lotus Notes アドレス帳データベースに、BlackBerry Desktop Manager と互換性のないカスタムテンプレートがあります。
解決策
BlackBerry スマートフォンユーザーの IBM Lotus Notes アドレス帳に標準テンプレートを適用します。
注意:標準テンプレートを適用したら、BlackBerry スマートフォンユーザーが連絡先を同期できることを確認します。 使用環境でカスタムテンプレートが広範囲に使用されている場合は、他の BlackBerry スマートフォンでもこの原因で同じ問題が発生する可能性があるため、この問題を BlackBerry スマートフォンユーザーの IT 部門に通知してください。
BlackBerry スマートフォンのアドレス帳が破損しています。
症状
- アドレス帳のエラーメッセージが次に該当する場合は、KB04317 を参照してください。
アドレスは外部で更新されました。 変更が失われ、ビューアが閉じます。
- Tif.log に、Microsoft Outlook の破損した連絡先エントリが記録されています。 Microsoft Outlook から連絡先を削除し、BlackBerry スマートフォンを再度同期しても、連絡先は BlackBerry スマートフォンに残ります。
- BlackBerry スマートフォンで新しい連絡先を作成すると、次のエラーメッセージが表示されます。
Uncaught exception Java.lang. no pointer exception(不明な例外 Java.lang。ポインタ例外はありません)
解決策
- 同期する前に BlackBerry スマートフォンをバックアップします。 詳細については、KB11625 を参照してください。
- アドレス帳データベースをクリアします。
-
- [バックアップと復元]を開き、[詳細]をクリックします。
- [アドレス帳]データベースを選択し、[クリア]をクリックします。
- BlackBerry スマートフォンをハードリセットします。 詳細については、KB02141 を参照してください。
-
BlackBerry スマートフォンを Microsoft Outlook と同期します。 KB05313 のタスク 3 の 2 番目のオプションを参照してください。
一時的なデータベースの破損により、BlackBerry スマートフォンが、カレンダー、メモリスト、およびタスクを含むオーガナイザアプリケーションの同期に失敗しています。
症状
オーガナイザアプリケーションに新しいエントリを作成すると、エラーが発生し、BlackBerry スマートフォンにエントリが作成されません。
解決策
BlackBerry スマートフォンをハードリセットします。詳細については、KB02141 を参照してください。
BlackBerry スマートフォンのアドレス帳に空白の連絡先があります。
解決策
アドレス帳の名前リストがアルファベット順に表示されている場合は、リスト最上位の <名前なし> を確認します。
名前フィールドで <名前なし> のエントリを削除します。
追加情報
上記の手順で問題が解決しない場合は、BlackBerry スマートフォンでデータとアプリケーションを削除して復元します。
BlackBerry スマートフォンでデータとアプリケーションを削除するには、次の手順に従います。
- [バックアップと復元]を使用して、BlackBerry スマートフォンのデータをバックアップします。 詳細については、KB11625 を参照してください。
- BlackBerry スマートフォンのすべてのデータとアプリケーションを削除します。 詳細については、KB02318 を参照してください。
BlackBerry スマートフォンアプリケーションを復元するには、次の手順に従います。
- Application Loader を使用して、BlackBerry Device Software を再インストールします。 詳細については、KB11320 を参照してください。
BlackBerry スマートフォンデータを復元するには、次の手順に従います。
- BlackBerry Desktop Manager で、[バックアップと復元]をダブルクリックします。
- [復元]をクリックし、BlackBerry スマートフォンのデータを削除する前に作成したバックアップファイルを選択します。
- [開く]をクリックします。 BlackBerry スマートフォンのデータが復元されます。