BlackBerry Desktop Manager で BlackBerry スマートフォンを検出できない
環境
- BlackBerry® Desktop Manager
- BlackBerry スマートフォン
問題
BlackBerry スマートフォンをコンピュータに接続している際、BlackBerry Desktop Manager がデバイスを検出できず、ステータスバーに[無効]と表示されます。
原因
このエラーには、複数の原因が考えられます。
考えられる原因
- BlackBerry Desktop Manager の接続設定が指定されていない可能性があります。
- クレードルが BlackBerry スマートフォンおよびコンピュータと通信していない可能性があります。
- BlackBerry スマートフォンが BlackBerry Desktop Manager と正しく通信していない可能性があります。
- 通信ポート(COM ポート)が使用できません。
- コンピュータの COM ポートが適切に通信していない可能性があります。
- USB ポート経由での通信に問題があります。
- BIOS(Basic Input/Output System)で COM ポートがオフになっている可能性があります。
- COM ポートドライバがインストールされていない可能性があります。
- 電源の管理がオンになっている可能性があります。
- BlackBerry スマートフォンが接続しているコンピュータがドッキングステーションを使用している可能性があります。
- サードパーティのドライバの競合により、USB ドライバが正しくインストールされていません。
- コンピュータに、BlackBerry スマートフォン用 Roxio® Media Manager のフルバージョンがインストールされています。
解決策
原因に対応した解決策を参照してください。
BlackBerry Desktop Manager の接続設定が指定されていない可能性があります。
解決策
次の手順に従います。
- BlackBerry Desktop Manager の[オプション]をクリックします。
- [接続設定]をクリックします。
- [検出]をクリックします。
- [OK]をクリックします。
クレードルが BlackBerry スマートフォンおよびコンピュータと通信していない可能性があります。
解決策
クレードルのパフォーマンスを確認するには、次のタスクを実行します。
- クレードルを使って、動作している別の BlackBerry スマートフォンをコンピュータに接続します。
- BlackBerry スマートフォンとクレードルを別のコンピュータに接続します。
- 別のクレードルをコンピュータに接続します。
BlackBerry スマートフォンが BlackBerry Desktop Manager と正しく通信していない可能性があります。
解決策
BlackBerry スマートフォンのパフォーマンスを確認するには、次のタスクを実行します。
- USB ケーブルが BlackBerry スマートフォンとコンピュータの両方に適切に接続されていることを確認します。
- BlackBerry スマートフォンを、別のコンピュータで動作しているクレードルに接続します。
- BlackBerry Desktop Manager 3.6 以前を使用している場合は、BlackBerry® Desktop Software と BlackBerry® Device Software のバージョンが一致していることを確認します。 ソフトウェアの最新バージョンについては、通信事業者にお問い合わせください。
- BlackBerry スマートフォンをハードリセットします。 詳細については、KB02141 を参照してください。
COM ポートは使用できません。
解決策 1
次のソフトウェアなどを無効にして、ポートの競合の可能性をなくします。
解決策 2
ポートの設定を確認します。
- コンピュータで[マイコンピュータ]を右クリックします。
- [プロパティ]を選択します。
- [ハードウェア]タブをクリックします。
- [デバイスマネージャ]をクリックします。
- [ポート]メニューツリーを展開し、目的のポートをダブルクリックします。
- [ポートの設定]タブで、次のように設定されていることを確認します。
|
ビット/秒 |
データビット |
パリティ |
ストップビット |
フロー制御 |
|
9600 |
8 |
マーク |
1 |
xon/xoff |
解決策 3
ポート速度を減速します。
- コンピュータで[マイコンピュータ]を右クリックします。
- [プロパティ]を選択します。
- [ハードウェア]タブをクリックします。
- [ポートのプロパティ]ウィンドウの[ポート設定]タブで、[ビット/秒]ドロップダウンリストからより遅い速度を選択します。
解決策 4
送信バッファ、および受信バッファのサイズを小さくします。
- コンピュータで[マイコンピュータ]を右クリックします。
- [プロパティ]を選択します。
- [ハードウェア]タブをクリックします。
- [ポートのプロパティ]ウィンドウの[ポートの設定]タブで、[詳細]をクリックします。
- [送信バッファ]および[受信バッファ]の設定値を小さくします。
解決策 5
COM ポートをアンインストールしてから再ロードします。
- コンピュータで[マイコンピュータ]を右クリックし、[プロパティ]を選択します。
- [ハードウェア]タブをクリックし、[デバイスマネージャ]をクリックします。
- [ポート(COM と LPT)]を展開します。
- 削除するポートを右クリックし、[アンインストール]を選択します。
- コンピュータを再起動すると、COM ポートが自動的に再ロードされます。
注意:Microsoft® Windows NT® を使用している場合は、COM ポートを削除しないでください。
解決策 6
WCESCOMM.EXE プロセスをオフにします。
- Ctrl + Alt + Del キーを押して、タスクマネージャを起動します。
- [プロセス]タブをクリックします。
- WCESCOMM.EXE を選択し、[プロセスの終了]をクリックします。
解決策 7
割り込みライン(IRQ)の競合や共有された IRQ がないことを確認します。
- コンピュータで[マイコンピュータ]を右クリックします。
- [プロパティ]を選択します。
- [ハードウェア]タブをクリックします。
- [ポートのプロパティ]ウィンドウを開きます。
- [リソース]タブをクリックします。 競合するデバイスがあれば、[競合するデバイス]に表示されます。
IRQ 設定を変更します。
- 解決策 2 の手順 1~3 を実行します。
- [リソース]タブをクリックし、[自動設定]チェックボックスをオフにします。
- [設定の登録名]ドロップダウンリストで、変更したいハードウェア設定を選択します。
- [リソースの設定]セクションで、[IRQ]を選択します。
- [設定の変更]をクリックします。 [IRQ の編集]ウィンドウが表示されます。
- リソースの種類に対して、変更後の値を入力します。
- [OK]をクリックします。
- [OK]をクリックします。
解決策 8
ポートを有効にします。
- コンピュータで[マイコンピュータ]を右クリックして、[プロパティ]を選択します。
- [ハードウェア]タブをクリックし、[デバイスマネージャ]をクリックします。
- [ポート]メニューツリーを展開し、目的のポートを右クリックして、[プロパティ]を選択します。
- [デバイスの使用状況]ドロップダウンリストから[このデバイスを使う(有効)]を選択します。
解決策 9
Microsoft® Windows® XP を使用している場合は、Microsoft Windows 2000 互換モードで BlackBerry Desktop Manager を実行します。
- DesktopMgr.exe ファイルを右クリックします。
- [プロパティ] > [互換性]を選択します。
- [互換モードでこのプログラムを実行する]チェックボックスをオンにします。
- ドロップダウンリストから[Windows 2000]を選択します。
コンピュータの COM ポートが通信していません。
解決策
コンピュータポートを通じて、通信の問題を解決します。
- コンピュータをドッキングステーション、またはポートレプリケータから取り外します。
- コンピュータから、PC カードをすべて取り外します。
IBM® ThinkPad® 600 コンピュータで BlackBerry スマートフォンが検出されない場合は、次の手順に従います。
Sony® PCG-XGP コンピュータで BlackBerry スマートフォンが検出されない場合は、ドッキングステーションのデフォルト COM ポートを CMOS の COM2 から COM1 に変更します。
- コンピュータで[マイコンピュータ]を右クリックして、[プロパティ]を選択します。
- [ハードウェア]タブをクリックし、[デバイスマネージャ]をクリックします。
- [ポート]を展開して、COM ポートの番号を確認します。
ポート番号を変更するには、次の手順に従います。
警告:コンピュータのレジストリを変更すると、Microsoft Windows オペレーティングシステムに重大な危害を及ぼす可能性があるため、 変更を行う前に、既存のレジストリエントリの記録およびバックアップを行ってください。
- [スタート] > [ファイル名を指定して実行]をクリックします。
- 「regedit」と入力して、 HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry\Manager\Settings を開きます。
- [接続の設定]を右クリックし、[変更]を選択して、使用するポート番号を入力します。
USB ポート経由での通信に問題があります。
解決策
次のようにして、USB 接続の問題を解決します。
- BlackBerry Desktop Manager の[オプション]をクリックします。
- [接続設定]をクリックします。
- [検出]をクリックします。
- USB 接続の検証を求められたら、[OK]をクリックします。 BlackBerry スマートフォンが検出されたかどうかを示すメッセージが表示されます。
- USB からシリアルへのコンバータを使用している場合は、互換性があることを確認します。
- コンピュータで使用されているオペレーティングシステムに、USB からシリアルへのコンバータとの互換性があることを確認します。
BIOS で COM ポートが無効になっている可能性があります。
解決策
BIOS で COM ポートを有効にし、この COM ポートに[自動]または[PnP]の値が割り当てられていることを確認します。
注意:BIOS によってユーザーインターフェイスは異なり、それに合わせて COM ポートを有効にする手順も異なります。 詳細については、通信事業者にお問い合わせください。
COM ポートドライバがインストールされていない可能性があります。
解決策
COM ポートドライバのインストール方法については、通信事業者にお問い合わせください。
電源の管理が有効になっている可能性があります。
解決策
デバイスマネージャの[USB ルートハブ]で電源の管理を無効にするには、次の手順に従います。
- コンピュータで[マイコンピュータ]を右クリックして、[プロパティ]を選択します。
- [ハードウェア]タブをクリックし、[デバイスマネージャ]をクリックします。
- [USB(Universal Serial Bus)コントローラ]を展開します。
- [USB ルートハブ]を右クリックし、[プロパティ]を選択します。
- [電源の管理]タブをクリックし、[電力の節約のために、コンピュータでこのデバイスの電源をオフにできるようにする]チェックボックスをオフにします。
- [OK]をクリックします。
- デバイスマネージャに表示されている各 USB ルートハブについて手順 4~6 を繰り返します。
BlackBerry スマートフォンが接続しているコンピュータがドッキングステーションを使用している可能性があります。
解決策
- コンピュータからドッキングステーションを取り外し、BlackBerry スマートフォンをコンピュータに直接接続します。
- Application Loader を使用して、BlackBerry Device Software を再インストールします。 詳細については、KB03621 を参照してください。
サードパーティのドライバの競合により、USB ドライバが正しくインストールされていません。
解決策
USB ドライバのインストールを確認します。
- コンピュータで[マイコンピュータ]を右クリックして、[プロパティ]を選択します。
- [ハードウェア]タブをクリックします。
- [デバイスマネージャ]をクリックします。
- [USB(Universal Serial Bus)コントローラ]で、[RIM Composite Device]または[BlackBerry Device]を右クリックします。
- [プロパティ]、[ドライバ]タブの順で選択して、[ドライバの詳細]を表示します。
- [ドライバの詳細]に RimUsb.sys 以外のドライバ(たとえば、LaCie Group の SIUSBFlt.sys)が含まれている場合は、それらのドライバを削除する必要があります。 問題のドライバの削除方法については、ベンダーにお問い合わせください。
注意:[プログラムの追加と削除]で LaCie Group のプログラムを探し、コンピュータから削除できます。 Windows エクスプローラを使用してドライバのファイル名を変更するだけでは、USB デバイスエラーの原因になる場合があります。
コンピュータに、BlackBerry スマートフォン用 Roxio® Media Manager のフルバージョンがインストールされています。 BlackBerry Desktop Manager 4.2.2 をインストールする際に BlackBerry スマートフォン用 Roxio® Media Manager をインストールするオプションを選択した場合は、BlackBerry Desktop Manager で BlackBerry スマートフォンを検出できません。 また、Microsoft Windows でも BlackBerry スマートフォンを検出できず、RIM COMPOSITE Driver が表示されます。
解決策
- Roxio Media Manager アプリケーションをコンピュータからアンインストールします。
- BlackBerry Desktop Manager の完全アンインストールを実行します。 詳細については、KB02206 を参照してください。
- BlackBerry Desktop Manager を、Roxio Media Manager オプションを選択して再インストールします。
対処方法
上記の解決策を実行しても問題が解決されない場合は、次を試してください。
『BlackBerryEnterprise Server アップグレードガイド』に従って、BlackBerry Desktop Software 3.6 以降にアップグレードします。
または
次の手順に従って、COM ポートの設定を修正してポート番号を変更します。
- [マイコンピュータ]を右クリックし、[プロパティ] > [ハードウェア] > [デバイスマネージャ] > [ポート(COM と LPT)]をクリックします。
- 変更の対象となる[通信ポート]をダブルクリックします。
- [ポート設定]タブをクリックし、[詳細]をクリックします。
- ドロップダウンリストから、[COM ポート]番号を変更します。
注意:COM ポートの名前を変更する場合、COM ポート番号に 8 よりも大きな値を選択しないでください。
- コンピュータを再起動します。
Microsoft Windows 98 または Microsoft Windows XP で上記のトラブルシューティングに失敗した場合は、次の手順に従います。
- [スタート] > [ファイル名を指定して実行]をクリックします。
- 「msconfig」と入力し、[OK]をクリックします。
- システム構成ユーティリティが開いたら、[system.ini]タブを選択し、[386Enh]を展開します。
- 「device=*enable」の隣にあるエントリをクリアします。
- [適用] > [OK]の順にクリックします。
- コンピュータを再起動します。
- コンピュータが再起動されたら、BlackBerry Desktop Manager を使用して、BlackBerry スマートフォンを検出します。
- クレードルの検出のために Microsoft Configuration ツールを使用するには、次のように[システム構成ユーティリティ]を開きます。
- [スタート] > [ファイル名を指定して実行]をクリックします。
- 「msconfig」と入力し、[OK]をクリックします。
- [スタートアップ]タブをクリックし、リストされている項目すべてのチェックマークをオフにします。
- [OK]をクリックします。
- [再起動]をクリックして、コンピュータを再起動します。
注意:コンピュータが再起動されると、タスクバーにはデフォルトのシステム要件のみリストされます。
追加情報
BlackBerry Desktop Manager 2.1.2 では、COM ポートはサポートされていません。 コンピュータには COM ポート 13 が表示されますが、13 ポートは BlackBerry Desktop Software の上限値を超えています。