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BlackBerry Desktop Manager が BlackBerry デバイスを検出できない

文書 ID: KB00125
最終更新日時: 3/9/2007 3
文書の種類: Support

環境設定

  • BlackBerry® Desktop Manager
  • BlackBerry デバイス



問題

BlackBerry デバイスをコンピュータに接続している際、BlackBerry Desktop Manager がデバイスを検出できません。 BlackBerry Desktop Manager のステータス バーには、[無効]と表示されます。




原因

考えられる原因

  1. BlackBerry Desktop Manager の接続設定が行われていない可能性があります。
  2. クレードルが BlackBerry デバイスおよびコンピュータと適切に通信していない可能性があります。
  3. BlackBerry デバイスが BlackBerry Desktop Manager と正しく通信していない可能性があります。
  4. COM ポートが使用できない状態にある可能性があります。
  5. コンピュータの COM ポートが適切に通信していない可能性があります。
  6. USB(Universal Serial Bus)が使用できない状態にある可能性があります。
  7. BIOS(Basic Input/Output System)で COM ポートが無効になっている可能性があります。
  8. COM ポートドライバがインストールされていない可能性があります。
  9. 電源の管理が有効になっている可能性があります。
  10. BlackBerry デバイスが接続しているコンピュータがドッキングステーションを使用している可能性があります。



解決策

原因 1

BlackBerry Desktop Manager の接続設定が行われていない可能性があります。

解決策

次の手順に従います。

  1. BlackBerry Desktop Manager の [オプション]メニューで[接続設定]をクリックします。
  2. [検出]をクリックします。
  3. [OK]をクリックします。

原因 2

クレードルが BlackBerry デバイスおよびコンピュータと適切に通信していない可能性があります。

解決策

クレードルのパフォーマンスを確認するには、次のタスクを実行します。

  • クレードルを使って、動作している別の BlackBerry デバイスをコンピュータに接続します。
  • BlackBerry デバイスとクレードルを別のコンピュータに接続します。
  • 別のクレードルをコンピュータに接続します。

原因 3

BlackBerry デバイスが BlackBerry Desktop Manager と正しく通信していない可能性があります。

解決策

BlackBerry デバイスのパフォーマンスを確認するには、次のタスクを実行します。

  • USB ケーブルが BlackBerry デバイスとコンピュータの両方に適切に接続されていることを確認します。
  • BlackBerry デバイスを、別のコンピュータで動作しているクレードルに接続します。
  • BlackBerry Desktop Manager 3.6 以前を使用している場合は、BlackBerry Desktop Manager ソフトウェアと BlackBerry Device Software のバージョンが一致していることを確認します。 最新バージョンのソフトウェアについては、担当のサービスプロバイダにお問い合わせください。
  • BlackBerry デバイスをハードリセットします。 詳細については、KB02141 を参照してください。

原因 4

COM ポートが使用できない状態にある可能性があります。

考えられる解決策

この問題については、次のような解決策が考えられます。

  • ポートの競合を解決します。
  • ポートの設定を確認します。
  • ポート速度を減速します。
  • 送信バッファ、および受信バッファのサイズを小さくします。
  • COM ポートをアンインストールしてから再ロードします。
  • WCESCOMM プロセスを無効にします。
  • IRQ の競合や共有がないことを確認します。
  • Device Manager を有効にします。
  • Windows 2000 互換モードで BlackBerry Desktop Manager を実行します。

 

解決策 A

次のソフトウェアなどを無効にして、ポートの競合の可能性をなくします。

  • 別の携帯端末(PDA)に使用している同期ソフトウェア
  • ActiveSync®(接続されているモバイルデバイスのシリアルポートを監視することにより、他のアプリケーションはこれらのポートを使用できなくなります) ActiveSync を無効にしてポートを解放するには、[COM ポートへの接続を許可する]チェックボックスを選択します。
  • ウイルス対策ソフトウェア
  • ファックスソフトウェア
  • モデムソフトウェア
  • BIOS 上の赤外線ポート

 

解決策 B

ポートの設定を確認します。

  1. デスクトップで、[マイ コンピュータ]を右クリックし、[プロパティ]を選択します。
  2. [ハードウェア]タブをクリックし、[デバイス マネージャ]をクリックします。
  3. [ポート]メニューツリーを展開し、目的のポートをダブルクリックします。
  4. [ポートの設定]タブで、次のように設定されていることを確認します。
ビット/秒 データビット   パリティ  ストップビット フロー制御
9600  8  マーク  1 xon/xoff
           

解決策 C

ポート速度を減速します。

  1. 解決策 B の手順 1 から 4 を行います。
  2. [ポートのプロパティ]ウィンドウの[ポート設定]タブで、[ビット/秒]ドロップダウンリストからより遅い速度を選択します。

解決策 D

送信バッファ、および受信バッファのサイズを小さくします。

  1. 解決策 B の手順 1 から 4 を行います。
  2. [ポートのプロパティ]ウィンドウの[ポートの設定]タブで、[詳細]をクリックします。
  3. [送信バッファ]および[受信バッファ]の設定値を小さくします。

解決策 E

COM ポートをアンインストールしてから再ロードします。

  1. デスクトップで、[マイ コンピュータ]を右クリックし、[プロパティ]を選択します。
  2. [ハードウェア]タブをクリックし、[デバイス マネージャ]をクリックします。
  3. [ポート (COM と LPT)]を展開します。
  4. 削除するポートを右クリックし、[アンインストール]を選択します。

注意:Microsoft® Windows NT® を使用している場合は、COM ポートを削除しないでください。

解決策 F

 
WCESCOMM.EXE プロセスを無効にします。
 
  1. Ctrl + Alt + Del キーを押して、タスクマネージャを起動します。
  2. [プロセス]タブをクリックします。
  3. WCESCOMM.EXE を選択し、[プロセスの終了]をクリックします。

解決策 G

割り込みライン(IRQ)の競合や共有された IRQ がないことを確認します。

  1. [ポートのプロパティ]ウィンドウを開きます。 解決策 B の手順 1 から 3 を参照してください。
  2. [リソース]タブをクリックします。 競合するデバイスがあれば、[競合するデバイス]に表示されます。

IRQ 設定を変更します。

  1. 解決策 B の手順 1 から 3 を行います。
  2. [リソース]タブをクリックし、[自動設定]チェックボックスをオフにします。
  3. [設定の登録名]ドロップダウンリストで、変更したいハードウェア設定を選択します。
  4. [リソースの設定]セクションで、[IRQ]を選択します。
  5. [設定の変更]をクリックします。 [IRQ の編集]ウィンドウが表示されます。
  6. リソースの種類に対して、変更後の値を入力します。
  7. [OK]をクリックします。
  8. [OK]をクリックします。

解決策 H

ポートを有効化します。

  1. デスクトップで、[マイ コンピュータ]を右クリックし、[プロパティ]を選択します。
  2. [ハードウェア]タブをクリックし、[デバイス マネージャ]をクリックします。
  3. [ポート]メニューツリーを展開し、目的のポートを右クリックして、[プロパティ]を選択します。
  4. [デバイスの使用状況]ドロップダウンリストから[このデバイスを使う (有効)]を選択します。

解決策 I

Windows XP を使用している場合は、Windows 2000 互換モードで Desktop Manager を実行します。


原因 5

コンピュータの COM ポートが適切に通信していない可能性があります。

解決策

コンピュータポートを通じて、通信の問題を解決します。

  • コンピュータをドッキングステーション、またはポートレプリケータから取り外します。
  • コンピュータから、PC カードをすべて取り外します。

IBM® ThinkPad® 600 コンピュータで BlackBerry デバイスが検出されない場合:

  • BIOS が最新の状態ではありません。 問題を解決するには BIOS を更新します。 詳細については、Microsoft Knowledge Base の記事 281965、281995、310560、180129 を参照してください。
 
Sony® PCG-XGP コンピュータで BlackBerry デバイスが検出されない場合:
 
ドッキングステーションのデフォルト COM ポートを、CMOS の COM2 から COM1 に変更します。
  1. デスクトップで、[マイ コンピュータ]を右クリックし、[プロパティ]を選択します。
  2. [ハードウェア]タブをクリックし、[デバイス マネージャ]をクリックします。
  3. [ポート]を展開して、COM ポートの番号を決定します。


ポート番号を変更するには:

警告:コンピュータのレジストリを変更すると、Microsoft Windows オペレーティングシステムに重大な危害を及ぼす可能性があるため、 変更を行う前に、既存のレジストリエントリを文書化し、バックアップしておいてください。

  1. [スタート] > [ファイル名を指定して実行]をクリックします。
  2. 「regedit」と入力して、 HKEY_CURRENT_USER\Software\Research In Motion\BlackBerry\Manager\Settings を開きます。
  3. [接続の設定]を右クリックし、[変更]を選択して、使用するポート番号を入力します。

原因 6

USB ポート経由での通信に問題があります。

解決策

次のようにして、USB 接続の問題を解決します。

  1. BlackBerry Desktop Manager の [オプション] > [接続設定]をクリックします。
  2. [検出]をクリックします。
  3. USB 接続の検証を求められたら、[OK]をクリックします。 デバイスが検出されたかどうかを伝えるメッセージが表示されます。
  4. USB からシリアルへのコンバータを使用している場合は、互換性があることを確認します。
  5. コンピュータで使用されているオペレーティングシステムに、USB からシリアルへのコンバータとの互換性があることを確認します。

詳細については、 『BlackBerry-supported USB adapters』(BlackBerry 対応 USB アダプタ)を参照してください。


原因 7

BIOS で COM ポートが無効になっている可能性があります。

解決策

BIOS で COM ポートを有効化し、この COM ポートに、[自動]または[PnP]の値が割り当てられていることを検証します。


原因 8

COM ポートドライバがインストールされていない可能性があります。

解決策

COM ポートドライバのインストール方法の詳細については、通信事業者に問い合わせてください。


原因 9

電源の管理が有効になっている可能性があります。

解決策

[デバイス マネージャ]の[USB ルート ハブ]で、電源の管理を無効化します。

  1. デスクトップで、[マイ コンピュータ]を右クリックし、[プロパティ]を選択します。
  2. [ハードウェア]タブをクリックし、[デバイス マネージャ]をクリックします。
  3. [USB (Universal Serial Bus) コントローラ]を展開します。
  4. [USB ルート ハブ]を右クリックし、[プロパティ]を選択します。
  5. [電源の管理]タブをクリックし、[電力の節約のために、コンピュータでこのデバイスの電源をオフにできるようにする]チェックボックスをオフにします。
  6. [OK]をクリックします。
  7. デバイスマネージャに表示されている各 USB ルート ハブについて、手順 1 から 4 を繰り返します。

原因 10

BlackBerry デバイスが接続しているコンピュータがドッキングステーションを使用している可能性があります。

解決策

  1. コンピュータからドッキングステーションを取り外し、BlackBerry デバイスを直接コンピュータに接続します。
  2. Application Loader ツールを使用して、BlackBerry Device Software を再インストールします。



対処方法

前述の解決策を実行しても問題が解決されない場合は、次を試してください。
 
BlackBerry Desktop Software をバージョン 3.6 以降にアップグレードします。
 
または
 
次の手順を実行して、COM ポートの設定を修正し、ポート番号を変更します。
 
  1. [マイ コンピュータ]を右クリックし、[プロパティ] > [ハードウェア] > [デバイス マネージャ] > [ポート (COM と LPT)]をクリックします。
  2. 変更の対象となる[通信ポート]をダブルクリックします。
  3. [ポート設定]タブをクリックし、[詳細]をクリックします。
  4. ドロップダウンリストから、[COM ポート]番号を変更します。

    注意:COM ポートの名前を変更する場合、COM ポート番号に 8 よりも大きな値を選択しないでください。
    コンピュータを再起動します。
 
Microsoft Windows 98、または Microsoft Windows XP を使用しているときに、上記のトラブルシューティングに失敗した場合は、次の手順を実行します。
  1. [スタート] > [ファイル名を指定して実行]をクリックします。
  2. [名前]フィールドに「 msconfig 」と入力し、[OK]をクリックします。
  3. システム構成ユーティリティが開いたら、[system.ini]タブを選択し、[386Enh]を展開します。
  4. 「device=*enable」の隣にあるエントリをクリアします。
  5. [適用] > [OK]の順にクリックします。
  6. コンピュータを再起動します。
  7. コンピュータが再起動されたら、BlackBerry Desktop Manager を使用して、BlackBerry デバイスを検出します。
クレードルの検出のために Microsoft Configuration ツールを使用するには、[システム構成ユーティリティ]を開きます。
  1. [スタート] > [ファイル名を指定して実行]をクリックします。
  2. [名前]フィールドに「 msconfig 」と入力し、[OK]をクリックします。
  3. [スタートアップ]タブをクリックし、リストされている項目すべてのチェックマークをオフにします。
  4. [OK]をクリックします。
  5. [再起動]をクリックして、コンピュータを再起動します。

注意:コンピュータが再起動されると、タスクバーにはデフォルトのシステム要件のみリストされます。




追加情報

BlackBerry Desktop Manager 2.1 Service Pack 2 では、COM ポートはサポートされていません。 コンピュータには COM ポート 13 が表示されますが、13 ポートは BlackBerry Desktop Software の上限値を超えています。



製品&サービス:

  • BlackBerry Desktop Software
  • BlackBerry デバイス